1. vinia
  2. Overige programmatuur en andere zaken
  3. zaterdag 08 november 2014
Beste Exel experts,
Ik heb een spreadsheet met o.a. kolom art.nr en kolom omschrijving.
Nu heb ik een nieuw blad gemaakt met kolommen art.nr. /omschrijving /prijs.
Ik zou graag op het sjabloon een art.nr. ingeven en dat dan in de kolom ernaast de omschrijving (soms 2 soms 3 regels) geplaatst wordt.
Volgens mij zou dit met vert.zoeken moeten kunnen maar ik krijg de formule niet voor elkaar.
Zou iemand mij kunnen helpen?
Bij voorbaat dank.
Victor
Reacties (1)
Geaccepteerd antwoord In Afwachting Moderatie
Beste Victor,


Laat ik eens proberen om wat licht in de duisternis te verschaffen. Daartoe heb ik een testspreadsheet gemaakt waaraan ik refereer.
Omdat ik geen Excel bestand kan versturen moet het maar in platte tekst.
In mijn testspreadsheet zitten twee gegevensbladen:
1. Sjabloon
2. Stamgegevens


Eerst maar eens blad 2. Hierin staan de volgende (stam)gegevens:
Artikel Omschrijving Prijs
1 Wortel € 0,05
2 Chocolade letter € 2,00
3 Suikerklontje € 0,01


Dan blad 1. Hierin kan je dus de invoer doen die automatisch de gegevens van blad 2 haalt. Je hoeft alleen maar Aantal en Artikel in te vullen, de rest volgt vanzelf.
Voorbeeld:
Aantal Artikel Details Prijs per stuk Totaal
5 1 Wortel € 0,05 € 0,25
2 2 Chocolade letter € 2,00 € 4,00
10 1 Wortel € 0,05 € 0,50


a. Op beide gegevensbladen heb je een sleutel nodig. In dit geval is dat het artikelnummer. Dat hoeft overigens niet op beide bladen hetzelfde te heten, maar dat is wel handig.
b. De sleutel van het 'opzoekblad' (in dit geval blad 2: stamgegevens) moet wel gesorteerd zijn anders loopt het mis.
c. In de kolommen Details (C) en Prijs per stuk (D) zitten dus de benodigde formules. Ik heb gebruik gemaakt van de functie VERT.ZOEKEN. In de cel voor Details staat dan "=VERT.ZOEKEN(B2;Stamgegevens!A:C;2;ONWAAR)". Dit betekent dat de waarde van cel B2 (artikel=1) wordt opgezocht in blad "Stamgegevens", kolommen A t/m C. Vervolgens wordt de 2e kolom van de stamgegevens (Omschrijving) in cel C2 gezet. In dit geval moeten de artikelnummers exact gelijk zijn (ONWAAR).
d. In de cel voor Prijs per stuk staat dan "=VERT.ZOEKEN(B2;Stamgegevens!A:C;3;ONWAAR)". Het enige verschil is dat de 3e kolom (Prijs) uit de stamgegevens wordt gehaald.
e. Totaal (kolom E) is gewoon Aantal vermenigvuldigd met Prijs per stuk.
f. Je moet nog even opletten dat de kolommen C en D in mijn voorbeeld exact dezelfde inhoud hebben. Microsoft wil nog wel eens 'met je mee denken' en verandert celreferenties tijdens het kopiëren.

Succes,
Pieter
  1. meer dan een maand geleden
  2. Overige programmatuur en andere zaken
  3. # 1
  • Pagina :
  • 1


Er zijn nog geen reacties op dit bericht.
Reageer als een van de eersten op dit bericht!
exHCClid
Je antwoord
Upload bestanden of afbeeldingen voor deze discussie door op de uploadknop hieronder te klikken. Ondersteund formaten: gif,jpg,png,jpeg,zip,rar,pdf
• Invoeren • Verwijder Upload bestanden (maximum bestandsgrootte: 2 MB)
Nog geen HCC-gebruikersaccount aangemaakt? Klik dan hier.

Inloggen