1. benwol
  2. Linux/Unix
  3. vrijdag 28 februari 2020
HTACCESS bestand werkt niet op Raspberry PI 4 ( werkt wel op Raspberry PI 3 )
Wie weet hier de oplossing voor?

.htaccess

AuthUserFile '/var/www/html/.htpasswd'
AuthName 'Wolhot'
AuthType Basic
Require valid-user
Reacties (16)
Geaccepteerd antwoord In Afwachting Moderatie
Graag meer info.
bijv. webserverconfiguratie en moduleconfiguratie.
Gebruik je de rewritemodule ?

p.s.
Wellicht handig om een Raspberrypi FAQ te maken.
Zeker gezien domotica-iot docker en de pi in een adem noemt.
  1. meer dan een maand geleden
  2. Linux/Unix
  3. # 1
Geaccepteerd antwoord In Afwachting Moderatie
Daarvoor moeten we de configuratie van de HTTP server bestuderen.
  1. meer dan een maand geleden
  2. Linux/Unix
  3. # 2
Geaccepteerd antwoord In Afwachting Moderatie
Hallo,Reageerders,
Ik schijn niet de enigste te zijn met dit probleem zie link hieronder

https://stackoverflow.com/questions/60366501/htaccess-not-working-in-raspberry-pi-4-model-b

alleen ik kom er niet uit hoe de oplossing is.

Ik heb apache2 en php 7. 0 geinstaleerd

https://www.transip.nl/knowledgebase/artikel/30-mappen-mijn-website-beveiligen-wachtwoord/

Wat is rewritemodule?
Gr. Ben
  1. meer dan een maand geleden
  2. Linux/Unix
  3. # 3
Geaccepteerd antwoord In Afwachting Moderatie
Welke directory zie ik niet in je .htaccess erbij staan.
http://lpic2.unix.nl/ch09.html#idm46195192290576

Je password file adverteren naar heel de wereld ?

AuthUserFile '/var/www/html/.htpasswd'
AuthName 'Wolhot'
AuthType Basic
Require valid-user


Dit komt meer in de richting.

<Directory /var/www/html>
AuthName "Wolhot"
AuthType Basic
AuthUserFile verzin een plekje maar niet op de webserver !
Require valid-user
Documentroot /var/www/html
</Directory>
  1. meer dan een maand geleden
  2. Linux/Unix
  3. # 4
Geaccepteerd antwoord In Afwachting Moderatie
Hallo Superbas,

Password staat er enkel in een versleutelde code in html
Deze htaccess file werkt pecfect op mijn Rasb pi 3 server ,maar dus niet op Rasp Pi 4
de enige aanvulling is "Documenroot/ var/www/html
Ik zal het proberen,

PS. Ik las ook iets over htaccess activeren ? wat is dat/moet dat ?/hoe doe je dat dan?
  1. meer dan een maand geleden
  2. Linux/Unix
  3. # 5
Geaccepteerd antwoord In Afwachting Moderatie
Een pwfile zet je niet op de webserver.
En nee "Documenroot/ var/www/html" is niet de enige aanvulling.
In .htaccess kun je modules activeren maar dat hoeft niet.
  1. meer dan een maand geleden
  2. Linux/Unix
  3. # 6
Geaccepteerd antwoord In Afwachting Moderatie
Hallo Superbas,
Ik heb onderstaand bestand geplaatst in var/www/html ,maar het werkt niet (geen enkel requester}

.htaccess

AuthName "Wolhot"
AuthUserFile /var/www/.htpasswd
AuthGroupFile /dev/null
AuthType Basic
require valid-user
Documentroot /var/www/html

PS. begrijp jij onderstaande link?

https://stackoverflow.com/questions/60366501/htaccess-not-working-in-raspberry-pi-4-model-b
  1. meer dan een maand geleden
  2. Linux/Unix
  3. # 7
Geaccepteerd antwoord In Afwachting Moderatie
Ik herhaal de vraag nog eens: hoe is je web server geconfigureerd?

Voor Apache heet het hoofdconfiguratiebestand doorgaans httpd.conf en is standaard te vinden in /etc/httpd/conf.
  1. meer dan een maand geleden
  2. Linux/Unix
  3. # 8
Geaccepteerd antwoord In Afwachting Moderatie
Hallo Dan the Man

Het bestand httpd.conf kan ik niet vinden .
Ik heb een deel van apache2.conf bijgesloten ( van wat ik heb aangepast/werkt overigens ook niet!)




<Directory />
Options FollowSymLinks
AllowOverride None
Require all denied
</Directory>

<Directory /usr/share>
AllowOverride None
Require all granted
</Directory>

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride All ( Hier heb ik None al vervangen door All )
Require all granted
</Directory>

#<Directory /srv/>
# Options Indexes FollowSymLinks
# AllowOverride None
# Require all granted
#</Directory>


# AccessFileName: The name of the file to look for in each directory
# for additional configuration directives. See also the AllowOverride
# directive.
#
AccessFileName .htaccess

#
# The following lines prevent .htaccess and .htpasswd files from being
# viewed by Web clients.
#
<FilesMatch "^\.ht">
Require all denied
</FilesMatch>
  1. meer dan een maand geleden
  2. Linux/Unix
  3. # 9
Geaccepteerd antwoord In Afwachting Moderatie
Hoi Ben,

Ik was het even vergeten maar het gebruik van .htaccess files word sterk afgeraden. Je kunt de authenticatie en authorisatie beter in de configuratie van de webserver neerzetten. Zie https://httpd.apache.org/docs/2.4/

Deel je plan van aanpak en je bevindingen dan kunnen we er een mooie Howto van maken!
  1. meer dan een maand geleden
  2. Linux/Unix
  3. # 10
Geaccepteerd antwoord In Afwachting Moderatie
Hallo Superbas,
Bedankt voor je reactie,maar hoe doe ik dat?

In de link documentatie Apacheserver staan ook htaccess bestanden
  1. meer dan een maand geleden
  2. Linux/Unix
  3. # 11
Geaccepteerd antwoord In Afwachting Moderatie
Beste Ben,

Verdiep je in het onderwerp en begin met lezen.
Bijvoorbeeld hier:
https://httpd.apache.org/docs/2.4/howto/access.html
https://httpd.apache.org/docs/2.4/howto/auth.html
  1. meer dan een maand geleden
  2. Linux/Unix
  3. # 12
Geaccepteerd antwoord In Afwachting Moderatie
Hallo Superbas,
Bedankt voor je inbreng maar dat wordt me te ingewikkeld.
Ik wil gewoon met een wachtwoord laten inloggen op mijn webserver.
Is de oude manier nou niet aan de praat te krijgen? op mijn RaspberryPI 4
Waar ligt dat aan ? De nieuwe Rasbian software voor Raspb. PI 4 ?
Gr Ben
  1. meer dan een maand geleden
  2. Linux/Unix
  3. # 13
Geaccepteerd antwoord In Afwachting Moderatie
Ben,

Ik stel voor om discussie voortzetten in het atelier hccersonderling
i.p.v. deze etalage.
  1. meer dan een maand geleden
  2. Linux/Unix
  3. # 14
Geaccepteerd antwoord In Afwachting Moderatie
Ik heb naar die apache2.conf file gekeken en voor mij ziet die er correct uit. Ik gebruik zelf nooit .htaccess files en specificeer de toegang gewoon in een .conf file. Ik zou het bestand met de wachtwoorden ook liever in /etc/httpd/ of zo bewaren.
  1. meer dan een maand geleden
  2. Linux/Unix
  3. # 15
Geaccepteerd antwoord In Afwachting Moderatie
Hallo dan the Man,Superbas,

Het lijkt er op dat het uiteindelijk gelukt is.
Na veel uitproberen
Het werkt !!!

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride All ( Hier heb ik None al vervangen door All )
Require all granted

Waarschijnlijk heeft de browser-cache / het proberen verhinderd, zodat het leek alsof het niet werkte.

Nog mijn dank voor het support
Gr. Ben
  1. meer dan een maand geleden
  2. Linux/Unix
  3. # 16
  • Pagina :
  • 1


Er zijn nog geen reacties op dit bericht.
Reageer als een van de eersten op dit bericht!
Nog geen HCC-gebruikersaccount aangemaakt? Klik dan hier.

Inloggen